Induction Status Broken (now resolved)
Incident Report for SignOnSite
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 02:26 UTC
Monitoring
We have released a fix & all systems should be back to normal. We will be monitoring support & metrics for a period to ensure the fix resolves the issue.

If you continue to experience issues, please contact support@signonsite.com.au as soon as possible.
Posted Sep 27, 2022 - 01:07 UTC
Identified
The cause of the issue has been confirmed to be the change we made late yesterday to our internal attendances endpoint (Confirming our hypothesis).

A fix is being worked on now and should be released into production within the next 2 hours.
Posted Sep 26, 2022 - 23:45 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 23:36 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 23:22 UTC
Investigating
We are aware of an issue causing induction statuses to show incorrectly in the web portal. This issue is actively being investigated, and we will release a fix as soon as we can.

We believe the the issue is only affecting viewing the induction status of individuals with induction workflows (submitting, reviewing, approving) being unaffected and working as normal.

Any data warehouse dashboards (PowerBI, DataStudio) and the customer API should be unaffected.

The issue was most likely introduced in our latest release of an internal API (not our customer API) last night whilst updating an endpoint. The update was to fix a performance problem causing timeouts on the attendance register, but the fix seems to have interacted unexpectedly with the inductions system. This is a working hypothesis and the cause hasn't yet been isolated and confirmed.

Updates will be posted on our statuspage (https://signonsite.statuspage.io/) as we have them.

The issue is expected to be resolved this morning.
Posted Sep 26, 2022 - 23:21 UTC
This incident affected: SignOnSite Field Platform (Website, iOS App).